Tags: usernein/pyromod
Tags
Release v3.1 (#40) * feature: register-next-step-handler (#35) * Handle filters if sync will use run_in_executor (#34) * async and sync for handler config (#36) * Support async and sync config handler * double import * feat: implement register_next_step_handler with execution of the registered callback (#37) * feat: receive listener data as list (#38) * feat: accept lists as chat_id, user_id, message_id and inline_message_id on listen, ask and wait_for_click * feat: accept lists as chat_id, user_id, message_id and inline_message_id on listen, ask and wait_for_click * async and sync for handler config (#36) * Support async and sync config handler * double import * feat: implement register_next_step_handler with execution of the registered callback (#37) * async and sync for handler config (#36) * Support async and sync config handler * double import --------- Co-authored-by: Juan Simon .D <72490350+jusidama18@users.noreply.github.com> * feat!: make stop_listening async and create stop_listener * docs: bump year on copyright * feat: accept usernames in listen (#39) * feat: accept usernames as chat_id and user_id on listen, ask and wait_for_click * Delete CNAME * Create CNAME * hotfix: fix syntax error * hotfix: fix login of lists in identifiers, fix call to remove_listener on future done * feat: add startup logs * docs: mention twice the telegram group in readme * feat: make register_next_step_handler support lists --------- Co-authored-by: Juan Simon .D <72490350+jusidama18@users.noreply.github.com>
release v3.0 (#33) * feat: remove identifier of listen() and ask() in favor of new kwargs * refactor: split classes into new files, extend from original classes * refactor: rename patch -> patch_into, patchable -> should_patch * style: format with ruff * feat(precedence): return most specific listener * refactor!: rename get_single_listener -> get_matching_listener, get_many_listeners -> get_many_matching_listeners * refactor: improve variable names and only remove checking attribute from null listener * refactor: transform config.py into package pyromod.config * chore!: remove handlers from pyromod exports * docs: bring new docs with docsify * docs: update README * Create CNAME * Delete CNAME * docs: add missing backtick * Create CNAME * fix: fix order of positional args in bound method ask * refactor(ask)!: rename request to sent_message * feat(ask): send message only if text is not empty * refactor: search for message_id (pyrogram v1) if message.id is not found * refactor: only use query.message.chat.id if both message and chat are not null * supports pyrogram v1 (#11) * supports pyrogram v1 * Update listen.py forgot, delete comma --------- Co-authored-by: Cezar H <pauxiscezar@gmail.com> * request to sent_message (#13) I think using the sent_message statement instead of request is much more descriptive * ask function will behave like listen if text is empty (#14) Co-authored-by: Cezar H <pauxiscezar@gmail.com> * Update for filters and if from_user is None (#17) * Update listen.py * Update listen.py * Update utils.py * Changes to be committed: modified: pyromod/listen/listen.py modified: pyromod/utils/utils.py * Changes to be committed: modified: pyromod/utils/utils.py * Changes to be committed: modified: pyromod/utils/utils.py * Changes to be committed: modified: pyromod/utils/utils.py * Update utils.py * Update utils.py * Update utils.py * Update utils.py * Update utils.py * Update utils.py * Update utils.py * Update utils.py * Changes to be committed: modified: pyromod/listen/listen.py * Update pyproject.toml * Update poetry.lock * Update poetry.lock * Update pyproject.toml * Update listen.py * Update listen.py --------- Co-authored-by: Cezar H <pauxiscezar@gmail.com> * feat: remove identifier of listen() and ask() in favor of new kwargs * refactor: split classes into new files, extend from original classes * refactor: rename patch -> patch_into, patchable -> should_patch * refactor: rename patch -> patch_into * style: format with ruff * chore: remaking many changes that got undone after the merge * refactor!: rename get_single_listener -> get_matching_listener, get_many_listeners -> get_many_matching_listeners * feat(precedence): return most specific listener * fix: replace @should_patch -> @should_patch() * fix: use Dict and List from typing instead of builtin --------- Co-authored-by: Tofik Denianto <77754555+tofikdn@users.noreply.github.com> Co-authored-by: Eikosa <darkofheking@gmail.com> Co-authored-by: Jusidama Bot <97734754+Jusidama-Bot@users.noreply.github.com>