8000 Suggestion: Rename, e.g., `AccountsService` property of `CoinbaseATClient` to `Accounts`, etc. · Issue #3 · confessore/CoinbaseAT · GitHub
[go: up one dir, main page]
More Web Proxy on the site http://driver.im/
Skip to content

Suggestion: Rename, e.g., AccountsService property of CoinbaseATClient to Accounts, etc. #3

New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Open
astrohart opened this issue Dec 27, 2023 · 1 comment
Assignees
Labels
enhancement New feature or request good first issue Good for newcomers help wanted Extra attention is needed

Comments

@astrohart
Copy link

Hello @confessore ,

May I make a suggestion for better semantics?

In your CoinbaseATClient class, there are properties

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IAccountsService AccountsService { get; }

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IFeesService FeesService { get; }

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IOrdersService OrdersService { get; }

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IProductsService ProductsService { get; }

I suggest they be named:

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IAccountsService Accounts { get; }

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IFeesService Fees { get; }

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IOrdersService Orders { get; }

        /// <summary>
        ///     <inheritdoc />
        /// </summary>
        public IProductsService Products { get; }

This naming style does seem to more closely resemble the convention for API clients.

@confessore
Copy link
Owner

this is a good idea.
definitely not in my mania at the moment.
would like to implement this; verbosity occurs sometimes 😅

@confessore confessore self-assigned this Jan 12, 2024
@confessore confessore added enhancement New feature or request help wanted Extra attention is needed good first issue Good for newcomers labels Jan 12, 2024
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
enhancement New feature or request good first issue Good for newcomers help wanted Extra attention is needed
Projects
None yet
Development

No branches or pull requests

2 participants
0